软件简介

前言：

    作为一款免费的冲模设计软件，虽然目前功能不如某些商业软件那样强大，但是随着越来越多的模具设计师们不断的提出宝贵的经验和建议，版本升级之快，功能完善之多，越来越受设计师们的喜爱，我相信不久的将来一定能和商业软件相媲美。我们的宗旨是：免费、高效、创新、超越。

软件资源：

  官方论坛：http://www.TsaiPress.cn
  QQ讨论群：3701103(限捐助用户)

TsaiPress冲模设计软件的特点:

  1.可保存各种组件的固定方式,便于下次调用,减少重复工作,提高工作效率;
  2.采用参数式,图像化的操作接口,好学易用,缩短学习时间;
  3.用户可自定各个模板的名称,甚至可以自定模板图层名/颜色,让您拥有符合自己习惯的设计软件;
  4.排料辅助功能可以对展形图进行全自动旋转测试,找出最省料的排料方式;
  5.模具图完成，即可产生详细的加工注解,以及零件、材料明细表,并可轻易输出到Excel;
  6.完全以加工的理念管理图层操作,简单便捷彻底解决冲模设计之图层管理问题;
  7.创意的图层复制功能将淡化图层的概念,而强调模具的各块模板;
  8.方便好用的多功能型“常用文字”可随叫随用,省掉文字输入之工作,并可选择多种文字输出方式;
  9.智能型的全自动模具尺度标注功能,节省您宝贵的时间;
  10.多种串接方式让您轻易的找到多段线未封闭处;
  11.自动化穿线孔、线割计价功能;
  12.批量打印让几十张模具图纸瞬间输出到打印机;
  13.创新的断面展开功能,只要轻点几下鼠标就可以自动画出展开断面图,和分步折弯、加入回弹后的断面图形;
  14.更重要的是软件是免费的,并且在不断的听取模具设计师的意见和创意,让您的想法也在软件中体现出来;
  15.更先进实用创新的功能正在加入到软件中!


版权信息

《TsaiPress冲模设计软件》使用和发布许可

    本软件为AutoCAD二次开发的外挂程序，仅提供作为应用上的参考，而未声明或隐含任何保证；对于任何特殊用途之适应性以及商业销售所隐含作出的保证，在此一概予以否认。
    本软件采用免费的方式发布，但是：
      1.软件版权属于其作者所有。
      2.所有人都可以无限期使用这个软件，且可免费升级。
      3.软件的许可类型是：地球上的任何一台计算机上均可使用本软件，但若要在其它星球上使用，需用当地星球上具统治地位的动/植物(相当于地球上的人)1PCS与作者换取此软件的使用权。
      4.软件是自愿使用的发布，没有任何明确或暗示形式的担保。您使用本软件要自己承担风险。不管是作者还是作者的代理，都没有责任对使用或误用本软件时的数据丢失、损坏、利益损失或其它任何形式的损失负责。
      5.除了在本协议中许可的条件外，您还可以自由发布，但不能用于商业目的的分发，如捆绑，销售，集成等，前提是发布的压缩包不做任何形式的修改，必须保证本软件的完整性。
      6.如果您不同意这个许可中的条款，您必须从您的存储设备中移除本软件并终止使用。
      7.安装或使用本软件意味着接受这些条款和这个许可的条件。
      8.所有在这里没有明确规定的权利，由作者保留。
    感谢您使用《TsaiPress冲模设计软件》。

流星蔡园
2007/09/11


TsaiPress命令列表

简化命令 | 命令全称 | 图标 | 命令描述
※颜色相关※
CT | TP_ColorTools |  | 更改图元颜色
CT1 | TP_ColorTools1 |  | 更改图元颜色1
CT2 | TP_ColorTools2 |  | 更改图元颜色2
CT3 | TP_ColorTools3 |  | 更改图元颜色3
CT4 | TP_ColorTools4 |  | 更改图元颜色4
CT5 | TP_ColorTools5 |  | 更改图元颜色5
CT6 | TP_ColorTools6 |  | 更改图元颜色6
CT7 | TP_ColorTools7 |  | 更改图元颜色7
CT8 | TP_ColorTools8 |  | 更改图元颜色8
※图层相关※
lk | TP_LockLayer |  | 选物锁其所在图层
lm | TP_MbLayerManager |  | 模板图层控制
CML | TP_CreateMouldLayer |  | 建立模具图层
q | TP_InlayOnOff |  | 切换当前模板的镶块层开关状态
` | TP_LayoutOnOff |  | 切换料带层"Layout"开关状态
LO | TP_LayoutSingleOn |  | 单开料带层"Layout"
+ | TP_LayerAllOn |  | 打开所有的图层(关闭的模板尺寸/文字层不会被打开)
++ | TP_LayerAllOn1 |  | 打开所有的图层
- | TP_CloseAllLayer |  | 关闭当前层以外的图层
TT | TP_ToLayerTxt |  | 将选择的文字图元更改到"Txt"图层中
TD | TP_ToLayerDim |  | 将选择的尺寸图元更改到"DIM"图层中
TC | TP_ToLayerCenter |  | 将选择的直线图元更改到"Center"图层中
TH | TP_ToLayerHidden |  | 将选择的除尺寸、文字以外的图元更改到"Hidden"图层中
LH | TP_LineHidden |  | 改变对象的线型为虚线
Alay |  |  | 图层加开
only |  |  | 输入层名单开层
+1,+2,+3,+4,+5,+6,+7,+8 |  |  | 加开相应的图层(图层"1"、"2"、"3"、..."8")
-1,-2,-3,-4,-5,-6,-7,-8 |  |  | 关闭相应的图层(图层"1"、"2"、"3"、..."8")
1,2,3,4,5,6,7,8 |  |  | 单开相应的图层(图层"1"、"2"、"3"、..."8")
T1,T2,T3,T4,T5,T6,T7,T8 |  |  | 选择图元将其更改到相应的图层(图层"1"、"2"、"3"、..."8")中
※功能增强※
qs | TP_QuickSelect |  | 快选过滤器
it | TP_InitTsaiPress |  | TsaiPress绘制环境初始化
CD | TP_ChangeDia |  | 批量改变圆的孔径
CCD |  |  | 改变单个圆或圆弧的直径
cc或cp | TP_Copy |  | 多重复制
tcc | TP_TextCopy |  | 文字增量复制
fn | TP_find |  | 文字查找与替换
fr | TP_Fillet_r |  | 倒r角
rf | TP_RegenFast |  | 局部快速重生成
lss | TP_ChangeLinetypeScale |  | 动态变更线型比例
stl | TP_SameToLayer |  | 将同类实体更改到指定图元所在的层
tl | TP_SelectEntryToLayer |  | 图元换层
lc | TP_LayerCorrect |  | 根据图元的不同属性将其更改到指定的图层
cl | TP_CurrentlyLayer |  | 选实体定当前层
pe | TP_PlineEdit |  | 合并为多段线
aj | TP_AutoJoin |  | 快速串接
ajj | TP_AutoJoin1 |  | 单一串接
EE | TP_EraseDimText |  | 增强删除
ou | TP_UserOsmode |  | 打开常用捕捉
sou | TP_SaveUserOsmode |  | 保存当前的捕捉设置，用于ou(TP_UserOsmode)命令调用
oa | TP_AllOsmode |  | 打开全部捕捉模式
oc | TP_CenterOsmode |  | 打开圆心捕捉模式
um | TP_UcsMove |  | 指定新的原点
fa | TP_FilletAllRadius |  | 多段线倒圆角
qx | TP_LineTan |  | 捕捉切点画直线
xo | TP_XlineOffset |  | 聚合线的偏移
ZZ | TP_PurgeAll |  | 图形整理(purge)
STT | TP_AllTextStyle |  | 解决文字显示成问号的问题
UT | TP_UserText |  | 常用文字
K | TP_SelectCommand |  | 根据用户选择的对象类形调用对应的命令
BJ | TP_ArcIntersection |  | 圆弧加尖角(用于标注与圆弧相切的两条直线的交点)
2o | TP_2Offset |  | 双向偏移
of | TP_PlineOffset |  | 多义线单边偏移
da | TP_DorAlign |  | 坐标标注对齐
daa | TP_DorAlign1 |  | 坐标标注对齐(增强)
da1 | TP_DimAlign |  | 线性标注对齐
DL | TP_overkill |  | 删除重复线
ROr | TP_RefreshOrdinate |  | 将坐标标注更新到当前坐标系
AC | TP_Arc2Circle |  | 将圆弧转换为圆
jx | TP_Rectang |  | 指定中心点和长宽画矩形
 | xh |  | 水平构造线
 | xv |  | 垂直构造线
drc | TP_DimRC |  | 标注指定多段线中的R角和C角
uo | TP_UcsByObj |  | 创建一个新的UCS以对齐到指定的对象上
fd |  |  | 细部放大
FF |  |  | 倒直角
CF |  |  | 倒C角
ZD、ZE、ZO |  |  | 视图缩放
 | TP_GroupSelectOnOff |  | 组选切换开关
 | TP_CreatesGroup |  | 快速创建新组
 | TP_ExplodesGroup |  | 分解编组
 | TP_PurgeGroups |  | 清理无用组
※TsaiPress图元绘制命令※
PD | TP_InlayDraw |  | 镶块外形绘制
bw | TP_MillingSlot |  | 避位槽绘制
dx | TP_DrawX |  | 作废打"X"符号
MF | TP_MaxFrame |  | 绘制出指定图元的最大外形
cen | TP_CenterLine |  | 画 圆/多义线 的中心线
cenn | TP_CircleCenterLine |  | 批量给圆孔加中心线
cs | TP_PunchSide |  | 冲头/镶块侧视图
gt | TP_Punch_YBC |  | 冲头/镶块压板槽绘制
sa | TP_StandardAutoInsert |  | 自动零件位
ss | TP_ScrewSide |  | 螺纹孔绘制
sn | TP_SerialNumber |  | 序列文字生成器,也可以用来生成球标文字
IH | TP_InsertHole |  | 孔生成
AE | TP_AlignEntity |  | 对象对齐工具
SSB |  |  | 插入描述部品技术要求的属性块(安装目录\blocks\bp-dh.dwg)
M4,M5,M6,M8,M10 |  |  | 在图档中插入相应大小的螺纹孔(块)
B4,B6,B8,B10 |  |  | 在图档中插入相应大小的销钉孔(块)
Y4,Y5,Y6,Y8,Y10 |  |  | 在图档中插入相应大小的螺丝沉头孔(块)
※TsaiPress图元编辑命令※
nb | TP_NewBlock |  | 新建块(-block)
tb | TP_FastBlock |  | 快速建块
rb | TP_ReplaceBlock |  | 批量替换块
 | TP_BlockRotation |  | 块的旋转角度归零
 | TP_DelBlockByName |  | 选块删同名块
UH | TP_UnionHole |  | 用于在制作料带时,将两个已冲的孔在后继工站合并为一个图元
PAR | TP_PitchArray |  | 步距阵列
DN | TP_DeleteNote |  | 清除块中指定属性的属性值文字
UB | TP_UpdateBlock |  | 模板信息更新至图框/属性块
LCP | TP_LayerCopy |  | 多重跨层复制
4M | TP_Mirror4 |  | 四角镜像
TI | TP_ToInlay |  | 选择图元换到镶块层
TP | TP_ToPlate |  | 选择图元换到模板层
bk |  |  | 单点打断
cr |  |  | 旋转复制
jd | TP_JD |  | 绘制截段线
※标注尺寸相关命令※
AOr | TP_AutoOrdinate |  | 自动坐标标注
FOr | TP_FrameOrdinate |  | 外框坐标标注
 | TP_AddDiaCode |  | 标注文字前加"Φ"
 | TP_AddScrewCode |  | 标注文字前加"M"
 | TP_AddBrackets |  | 标注文字前后加括号
N2 | TP_Count2 |  | 标注加数量前缀"2-"
N3 | TP_Count3 |  | 标注加数量前缀"3-"
N4 | TP_Count4 |  | 标注加数量前缀"4-"
N5 | TP_Count5 |  | 标注加数量前缀"5-"
N6 | TP_Count6 |  | 标注加数量前缀"6-"
N7 | TP_Count7 |  | 标注加数量前缀"7-"
N8 | TP_Count8 |  | 标注加数量前缀"8-"
N9 | TP_Count9 |  | 标注加数量前缀"9-"
CC1 | TP_LeaderC1 |  | 标注倒角C1.1
CC2 | TP_LeaderC2 |  | 标注倒角C2.1
CC3 | TP_LeaderC3 |  | 标注倒角C3.1
QQ | TP_Dimdec |  | 批量改变标注的小数点位数
Q` | TP_Dimdec0 |  | 改变标注的小数点为0位
Q1 | TP_Dimdec1 |  | 改变标注的小数点为1位
Q2 | TP_Dimdec2 |  | 改变标注的小数点为2位
Q3 | TP_Dimdec3 |  | 改变标注的小数点为3位
DC | TP_DimCheck |  | 检查标注尺寸上的文字是否被手工修改过
※TsaiPress标准件绘制※
SD | TP_StandardMain |  | 标准件绘制
scr | TP_Screw |  | 螺丝
GP | TP_GuidePin |  | 内导柱
GLP | TP_GuideLifterPin |  | 浮升导料销
Spring | TP_Spring |  | 弹簧
DP | TP_DowelPin |  | 销钉
PP | TP_PilotPin |  | 导正销
SSt | TP_SpoolStopper |  | 等高套筒
SB | TP_StripperBolt |  | 等高螺丝
LP | TP_LifterPin |  | 浮升销
AP | TP_ShoulderPunch |  | A冲
APP | TP_ShoulderPunch1 |  | 异形A冲
BP | TP_StraightPunch |  | T冲
REF | TP_Benchmark |  | 基准孔
Gu | TP_GuidePlate |  | 导料板绘制
※TsaiPress模具设计命令※
Minf | TP_MouldInf |  | 模具资料设置
ZK | TP_Extension |  | 断面展开
PY | TP_AutoLayout |  | 排样辅助
mc | TP_MouldClass |  | 模具结构设置
MB | TP_MbSet |  | 模板设置与绘制
CMC | TP_MouldClassChg |  | 切换模具结构环境
HL | TP_HoleLayer |  | 异形孔分层
IL | TP_InlayLayer |  | 镶块分层
OL | TP_OtherLayer |  | 其它加工(增加标签)
csk | TP_csk |  | 穿丝孔
nt | TP_Note1 |  | 文字注解输出
cn | TP_Note2 |  | 坐标注解输出
XM | TP_XDataModify |  | 标签修改
XCP | TP_xDataCopy |  | 标签复制
CX | TP_XdataClear |  | 标签清除
mbfl | TP_mbfl |  | 模板分离
BOM | TP_MbBOM |  | 模板材料表
b2e | TP_Bom2Excel |  | 发送模板材料表到Excel
sBOM | TP_StandardBOM |  | 五金标准件清单
IML | TP_InsertMouldLabel |  | 插入模具铭牌
zl | TP_ASM_Bottom |  | 下侧组立图
zll | TP_ASM_Right |  | 右侧组立图
as | TP_AddStandardSide |  | 加组立图零件
※图框与打印※
UA | TP_UserAttdef |  | 用户字段编辑
ip | TP_InitPrinter |  | 打印机初始化(快速打印)
A4 | TP_InsertFrameA4 |  | 插入A4图框(安装目录\blocks\A4.dwg)
A3 | TP_InsertFrameA3 |  | 插入A3图框(安装目录\blocks\A3.dwg)
AA3 | TP_InsertFrameAA3 |  | 插入带模板属性块的A3图框(安装目录\blocks\AA3.dwg)
P4 | TP_PrintA4 |  | A4纸打印
P3 | TP_PrintA3 |  | A3纸打印
BP4 | TP_BatchPrintA4 |  | A4纸批量打印
BP3 | TP_BatchPrintA3 |  | A3纸批量打印
※其它※
wc | TP_WireCut |  | 调用TsaiPress线割计价软件
te | TP_Text2Excel |  | 选择文字发送到Excel
LIB | TP_LIB |  | 图库
用户可更改TsaiPress的简化命令,位于菜单"TsaiPress"->"编辑资料档案"->"简化命令",更改完成后执行recmd命令以使新的简化命令立即生效。

※连续模图层控制命令※
模板名称 | 单开 | 加开 | 单开铣床层 | 单开线割层 | 单开镶块层
上模座 | 11 | `1 | 1Q | 1A |
上垫板 | 22 | `2 | 2W | 2S |
上夹板 | 33 | `3 | 3E | 3D | 1i
止挡板 | 44 | `4 | 4R | 4F |
上脱板 | 55 | `5 | 5T | 5G | 2i
下模板 | 66 | `6 | 6Y | 6H | 3i
下垫板 | 77 | `7 | 7U | 7J |
下模座 | 88 | `8 | 8I | 8K |
其它:
ii | 开上夹板、脱料板、下模板镶块层和冲头层
PH | 单开冲头层
说明: 1.关于单开铣床层和单开线割层大家不要记命令名称,而是以键盘位置来记忆; 2.命令在软件安装目录\menu\TsaiPress0.lsp中更改; 3.连续模图层命令在 安装目录\menu\TsaiPress0.lsp 中修改。


软件教程

  1. 绘图前的准备工作
    • 绘图环境初始化
    • 模具资料设置
    • 用户字段编辑
    • 模具结构设置
  2. 模板绘制
    • 模板设置与绘制
    • 模板设置修改
  3. 零件绘制
    • 标准件绘制
    • 异形分层
    • 镶块分层
    • 加穿丝孔
    • 其它加工(增加标签)
  4. 组立图
    • 半自动组立图
    • 加组立图零件
  5. 图纸生成
    • 模板材料规格表
    • 标准件清单
    • 注解输出
    • 尺寸标注
    • 插入图框
    • 模板分离
    • 打印输出

(以上是以绘制一套完整模具的先后过程作排序)


绘图前的准备工作

  • 绘图前的准备工作
    1. 绘图环境初始化
    2. 模具资料设置
    3. 用户字段编辑
    4. 模具结构设置


绘图环境初始化

"绘图环境初始化"用于设置当前AutoCAD环境，包括设置常用变量、新建文字样式、新建标注样式、建立用户自定义图层。

图标：无
命令：IT
菜单："TsaiTools"->"TsaiPress绘图环境初始化..."
界面：

说明：

  • 本命令设置的内容包下列AutoCAD变量：PICKBOX，UCSICON，DIMASSOC，PICKSTYLE，MIRRTEXT，CELTYPE，CECOLOR，CELTSCALE，CELWEIGHT，THICKNESS，SaveTime，MBUTTONPAN，以及：十字光标大小，屏幕菜单，滚动条，默认打印样式表。
  • 新建的文字样式名是TsaiPress，它的字体在菜单"TsaiPress"->"选项"->"文字样式"->"常规文字样式"中设置。
  • 新建的标注样式名有Standard、Standardx15、Standardx20、Standardx25，它们之间的区别在于标注比例不同。
  • 建立的自定义图层中菜单"TsaiPress"->"编辑资料档案"->"用户自定义图层"中修改。
  • "线性标注精度"是指新建的各个标注样式的小数点位数。


模具资料设置

"模具资料设置"用于保存最基本的模具信息，这些信息用于自动填写到图框、模板材料规格表、标准件清单以及模具标签等表格中。

图标：
命令：Minf
菜单："TsaiPress"->"模具资料设置..."
界面：

说明：

  • 可以手工输入各项资料，也可点输入框后面的 [image] 图标从图档中拾取文字填入到输入框。
  • 输入完成后，点"保存"->"关闭"，这样会自动填写此处的资料至后续插入的图框、模板材料规格表、标准件清单及模具标签中。
  • 点"更新"后可以将资料填写到选择的图框或属性块中。
  • 如果在图框、模板材料规格表、标准件清单以及模具标签等表格中出现了此处没有的资料项目，请使用"用户字段编辑"功能添加。
  • 动画教程:


用户字段编辑

"用户字段编辑"用于保存最用户自己的模具信息，这些信息用于自动填写到图框、模板材料规格表、标准件清单以及模具标签等表格中。

图标：无
命令：UA
菜单："TsaiTools"->"用户字段编辑..."
界面：

说明：

  • 本功能是对"模具资料设置"的补充，用于自定"模具资料设置"中没有的资料项目。
  • 输入完成后，点"保存"->"关闭"，这样会自动填写此处的信息至后续插入的图框、模板材料规格表、标准件清单及模具标签中。
  • 点"更新"后可以将资料填写到选择的图框或属性块中。
  • 用户可在菜单"TsaiPress"->"选项"->"用户字段"中修改、添加或删除字段。


模具结构设置

"模具结构设置"用于设置模具的结构类型。

图标：
命令：Mc
菜单："TsaiPress"->"模具结构设置..."
界面：

说明：

  • 目前支持五种模具结构，分别是连续/冲孔模、复合模、及三种常见的折弯模结构。
  • 在进行后续操作前必须先设置好模具结构。


模板绘制

  • 模板绘制
    1. 模板设置与绘制
    2. 模板设置修改


模板设置与绘制

"模具设置与绘制"用于绘制模板，及修改模板的厚度、材质等。

图标：
命令：MB
菜单："TsaiPress"->"模板设置与绘制..."
界面：

说明：

  • 执行本命令前请先进行"模具结构设置"，并画好代表模板、模座和垫脚的矩形外框（需串接成多段线）。
  • 在需要绘制的模板名称前打"√"，然后输入各模板的厚度，并选择材质及热处理。
  • 根据实际情况填写模具参数设置中的各项(脱料板行程、冲剪冲头长和冲裁间隙)。
  • 所有项目设置好后点击"模板绘制"按钮，然后根据命令提示行信息分别选择事先画好的代表模板、模座和垫脚的矩形外框。如果是复合模结构会提示你先选择下料外形图元。
  • 模板绘制完成后"模板规格表"和"导出模板规格"这两个按钮将变成可点状态，点"模板规格表"会在图档中插入用于订购模板材料的表单，点"导出模板规格"会将此表单导出到Excel中，并在Excel中计算好模板的重量、模板金额及热处理金额等。
  • 模板的层名、默认的厚度、材质、热处理、导出到Excel中用于计算模板重量的材料比重、用于计算模板金额的材料单价和用于计算热处理金额的热处理单价可以通到菜单"TsaiPress"->"编辑资料档案"->"模板资料档"中进行设置。
  • 不同结构的模板不要相互复制。
  • 动画教程：


模板设置修改

如果模板已经绘制画,还可以随时修改模板模板的厚度、材质等，也可以增加或删除模板。

图标：
命令：MB
菜单："TsaiPress"->"模板设置与绘制..."
界面：

说明：

  • 输入新的模板厚度、材质或热处理，或者清除/勾选模板后，"应用修改"按钮将变成可用状态。
  • 点"应用修改"后新的设置值将重新写入到图档中的各模板图元，如果新勾选了模板，请按提示选择预先画好的模板外框来新增模板。
  • 模具参数设置中的各项值(脱料板行程、冲剪冲头长和冲裁间隙)如作了修改，关闭对话框后将会被保存。
  • 修好模板后如已生成了模板材料规格表，需删除后重新生成。


零件绘制

  • 零件绘制
    1. 标准件绘制
    2. 异形分层
    3. 镶块分层
    4. 加穿丝孔


标准件绘制

"标准件绘制"用于绘制各种标准件，如内/外导柱、螺丝、弹簧等等，以及各标准件的零件图。

图标：
命令：SD
菜单："TsaiPress"->"标准件绘制"
界面：

说明：

  • 左键单击界面上各图片可进入相应的标准件绘制对话框。
  • 右键单击界面上各图片可进入相应的标准件零件图绘制对话框。
  • 标准件是以编组形式保存的，编组打开(Ctrl+H)时点击标准件的其中一个图元就可以选中整个标准件图元，方便移动、复制等操作。
  • 动画教程(以绘制A冲为例):


异形分层

"异形分层"用于将各种异形孔如异形冲孔、折弯冲、插刀等复制到各模板层，并写入各种用于注解输出的信息如说明文字、间隙、加工要求。

图标：
命令：HL
菜单："TsaiPress"->"异形孔绘制"->"异形孔分层"
界面：

说明：

  • 设置好各项后点击"执行"选取预先画好的框口(需串接成多段线)。
  • 冲头长度是调用的"模板设置与绘制"中的"冲剪冲头长"的相对值。
  • 如果哪一块模板的间隙需调用"模板设置与绘制"中的"冲裁间隙"处的数值，请填入"C"再按"保存"按钮，重新执行此命令即可。
  • 动画教程(以绘制异形冲孔为例):


镶块分层

"镶块分层"用于将各种镶块和镶块孔进行分层，并写入各种用于注解输出的信息如说明文字、间隙、加工要求。

图标：
命令：IL
菜单："TsaiPress"->"异形孔绘制"->"镶块分层"
界面：

说明：

  • 设置好各项后，先点击1号按钮从图档中选取预先画好的镶块孔框口图元，再点击2号按钮选择镶块外形图元，然后点"执行"后要求用户选择镶块孔内部的孔，这些孔会由原来的模板层自动换到镶块层。
  • 镶块孔框口图元可用PD命令辅助生成。
  • 大多数情况下镶块孔框口图元与镶块外形图元是指同一个图元，即1号按钮和2号按钮选择的是同一个图元，可以在按2号按钮后提示选择对象时直接按P。
  • 3号按钮与2号按钮作用相同，用在同一个镶块孔里是由两个镶块拼起来的情形。
  • 动画教程(以绘制冲孔镶块为例):


加穿丝孔


其它加工(增加标签)


组立图

  • 组立图
    1. 半自动组立图
    2. 加组立图零件


半自动组立图


加组立图零件


图纸生成

  • 图纸生成
    1. 模板材料规格表
    2. 标准件清单
    3. 注解输出
    4. 尺寸标注
    5. 插入图框
    6. 模板分离
    7. 打印输出


模板材料规格表


标准件清单


注解输出


尺寸标注


插入图框


模板分离


打印输出


软件自定义

  • 自定义图框
  • 卷圆产品的展开
  • 标准件规格修改、添加和删除


自定义图框

用户自定义图框的方法：

  1.首先打开你自己的图框,在图框内插入相应的属性(定义属性的命令是AttDef)，属性的位置、文字大小等可任意自定，最多可插入12个用户属性；
  2.将图框的左下角移动到0点；
  3.执行AutoCAD命令purge清理图档中无用内容，再将图框保存到TsaiPress软件安装目录下的blocks文件夹下，A3图框保存的文件名是A3.DWG，A4图框保存的文件名是A4.DWG；
  4.依次打开菜单"TsaiPress->选项->用户字段"，在弹出的对话框中的"字段名"栏中填入第1步插入到图框中的属性，"默认值"栏可选填，全部填完后点"确定"退出；
通过以上步骤你自己的图框就设置完成了，每次填写好"用户字段编辑 "后再插入图框时将自动更新这些图框的属性的值。


卷圆产品的展开：


更新历史

V1.8 更新内容
     2009.11.16 新增步距移位命令PM(TP_PitchMove)。
    2009.11.16 增加标签命令OL(TP_OtherLayer)增加了剖面线填充功能。
    2009.11.12 增加了在"模板分离"时对分组模板的处理。
    2009.11.05 增加命令daa(命令全称:TP_DorAlign1),用于坐标标注对齐,并对重叠的标注进行自动避让。
    2009.11.04 "模板设置与绘制"界面上增加"存"和"读"两个按钮,用于临时保存模板的设置数据。
    2009.10.27 "模板资料设置"和"步距阵列"中的"步距"改为可以输入负数,用于向左边方向阵列。
    2009.10.23 新增3个与群组有关的功能：
                        快速创建新组,命令:TP_CreatesGroup。
                        分解编组,命令:TP_ExplodesGroup。
                        清理无用组,命令:TP_PurgeGroups。
    2009.10.23 新增功能：给选择的标注文字前后加括号,命令:TP_AddBrackets。
    2009.10.22 新增功能：四角镜像,命令4M(TP_Mirror4)。
    2009.10.19 修正了批量给圆孔加中心线命令cenn(TP_CircleCenterLine)对于同心圆重复加中心性的问题。
    2009.10.18 在"模板分离"时，增加选择标注基准点的选项。
    2009.09.25 新增命令:uo(TP_UcsByObj),创建一个新的UCS以对齐到指定的对象上。
    2009.09.24 新增命令:jd(TP_JD),用于绘制截段线。
    2009.09.22 新增命令:zll(TP_ASM_Right),用于生成右侧组立图。
    2009.09.18 新增命令:da1(TP_DimAlign),用于将线性标注尺寸对齐。
    2009.09.16 新增命令:TP_DimCheck,用于检查标注尺寸上的文字是否被手工修改过。
    2009.09.15 修正了复合模和折弯模单开上模时的BUG。
    2009.09.07 孔生成命令(命令全称:TP_InsertHole)增加绘制孔侧视图的功能。
    2009.09.04 跨层复制命令LCP功能增强,可以跨层复制的同时偏移图元。

V1.7.2 更新内容
     2009.07.28 新增对象对齐工具,命令全称:TP_AlignEntity。
    2009.07.23 新增将产品计算、材料利用率等导入绘图区的功能,命令全称:TP_PressCalc。
    2009.07.21 新增两种弹簧组件的固定方式,命令全称:TP_SpoolStopperKz。
    2009.07.20 新增孔生成命令,命令全称:TP_InsertHole。
    2009.07.09 标签复制增加可设置是否将常用特征一起复制到目标图元。
    2009.06.30 新增一种注解输出方式,命令全称:TP_Note2。
    2009.06.16 新增独立导柱绘制功能,命令全称:TP_MyGuidePost。

V1.7.1 更新内容
     2009.05.07 新增导料板绘制功能,命令全称:TP_GuidePlate。
    2009.05.05 "销钉绘制"中的"模板名称"增加冲头层。
    2009.04.21 "螺丝绘制"中的"模板名称"增加冲头层。
    2009.04.14 弹簧孔加修饰线条以方便区分。
    2009.03.10 外框标注功能增强，可对选择的多个外框同时进行标注。

V1.7 更新内容
     2009.01.15 水平坐标对齐和垂直坐标对齐命令合并成一个命令:da(TP_DorAlign)。
    2009.01.14 新增序列文字生成器，命令:sn(TP_SerialNumber)，也可以用它来生成球标文字。
    2009.01.13 新增快选过滤器，命令:qs(TP_QuickSelect)。
    2009.01.13 新增文字增量复制，命令:tcc(TP_TextCopy)。
    2009.01.12 新增命令:sou(TP_SaveUserOsmode),用于保存当前的捕捉设置，便于ou(TP_UserOsmode)命令调用。
    2009.01.08 新增对英制螺丝的支持，在菜单"TsaiPress"->"选项"->"标准件设置"中指定公制或英制。
    2009.01.07 新增命令:drc，命令全称:TP_DimRC，用于标注指定多段线中的R角和C角。
    2008.12.31 新增tb命令，用于快速建块。
    2008.12.29 增加了在"模板分离"时自动注解输出的功能。
    2008.12.23 用户可自定"模板分离"时模板的放置位置,位于菜单"TsaiPress"->"编辑资料档案"->"模板资料档",其中的"行"和"列"。
    2008.12.12 用户可更改TsaiPress的简化命令,位于菜单"TsaiPress"->"编辑资料档案"->"简化命令",更改完成后执行recmd命令以使新的简化命令立即生效。
    2008.12.12 解决了一些命令按回车键不能重复执行的BUG。
    2008.12.11 增加了在"模板分离"时自动标坐标的功能。
    2008.12.10 取消了"模板分离"时要输入分离间距。

V1.6 更新内容
     2008.12.09 增加在"模板分离"时自动套图框。
    2008.12.03 增加图库功能，命令LIB。
    2008.11.28 命令:cen增加了给圆弧加中心线的功能(原只能给多段线和圆加中心线)。
    2008.11.27 修正了图层归正(命令:LC)不处理中心线的BUG。
    2008.11.24 修正了"排样辅助"命令有些情况下会死机的问题。
    2008.11.19 新增UH命令,用于在制作料带时,将两个已冲的孔在后继工站合并为一个图元。
    2008.11.15 增强了步距阵列(命令:par)的功能,用户可设置阵列生成的图元的颜色、图层。

V1.5 更新内容
    2008.11.13 新增Q命令,用于切换当前模板的镶块层开关状态。
    2008.11.13 新增`(Esc键下面那个)命令,用于切换料带层开关状态。
    2008.11.12 改进了安装程序,用户现可以选择安装到的AutoCAD版本。
    2008.11.12 排料辅助功能增强-用户可以自己选择不同的旋转角度自动画出排样图。
    2008.11.10 新增 批量给圆孔加中心线命令cenn.
    2008.11.03 增加更改图元颜色的命令,分别是ct、ct1、ct2、ct3...ct8.
    2008.10.31 增加双向偏移命令2O.
    2008.10.29 增加透明命令找指定两点的中点(在工具栏中).
    2008.10.29 增加qx命令,用于捕捉切点画直线.
    2008.10.28 取消了ET(删文字)命令,将ED(删尺寸)还给CAD,并将这两个命令合并成了EE(增强删除)命令.
    2008.10.27 "选物单开"更改为可以同时选择多个图元(原只能选择一个),将其图层都打开,其它层关闭.
    2008.10.25 "自动绘穿丝孔"增加了对小孔加放电穿丝孔的功能。
    2008.10.24 重写了安装程序，支持AutoCAD2004~2008中英文版的自动安装。
    2008.10.16 新增在外框标注和坐标标注时，自动判断小数点位数.

V1.4.5 更新内容
    2008.10.14 更正了注解输出时负间隙显示错误的BUG.
    2008.09.18 增加设置选项"坐标共线之图元间距阀值"
    2008.09.04 加入了一些连续模结构的模板图层控制命令(安装目录menu下的TsaiPress0.mnl和TsaiPress0.lsp文件)，其它模具结构的可以依此为参照,自己建立相应的文件将模板图层控制命令加进去.
    2008.09.04 取消"孔序号",注解输出时会自动编号.
    2008.08.26 原XL和YL命令改为XH和XV.
    2008.08.19 加了一个打开全部捕捉的命令OA,打开常用捕捉命令改成了OU,打开圆心捕捉命令改成了OC.
    2008.08.18 注解输出中模板厚度增加可由用户自定义小数点位数的功能.(菜单"TsaiPress"->"编辑资料档案"->"模板资料档").
    2008.08.18 注解输出中铰孔和镗孔的孔径小数点修正为2位.
    2008.08.15 外框标注功能作了改进.
    2008.08.15 批量打印加了快捷命令:BP4和BP3,分别对应A4纸批量打印和A3纸批量打印.

V1.4.4 更新内容
    2008.08.05 对穿丝孔命令的算法进行了少许改进,并亮显成功添加了穿丝孔的图元.
    2008.07.30 "圆弧变尖(命令:BJ)"增加了三点定圆弧的功能,这样多段线就不用炸开就可以画出交点了.
    2008.07.30 工具栏上加了一个组选开关按钮.
    2008.07.25 增加两个命令TI和TP:
              TI(ToInlay):将选择的图元分别换层到镶块机加工层和线割层;
              TP(ToPlate):将选择的图元分别换层到模板机加工层和线割层.
    2008.07.24 修正了镶块分层命令时,选择的镶块孔图元所在层如被锁定,会发生错误.
    2008.07.22 增加对穿丝孔放置层的设置,可选择放在线割层或者机加工层.
    2008.07.22 增加对自动坐标标注文字的自动避让.

V1.4.3 更新内容
    2008.07.11 软件选项里增加了下列4个选项:
                外框标注完成后进行坐标标注
                坐标标注时是否指定标注小数点位数
                外框坐标标注默认小数点位数
                自动坐标标注默认小数点位数
    2008.07.10 修正了在AutoCAD2006上安装不成功的问题.
    2008.07.08 新增命令:K (根据用户选择的对象类形调用对应的命令，比如用户选择文字则调用文字命令，选择坐标标注则调用坐标标注命令)

V1.4.2 更新内容
    2008.07.07 增加常用文字功能，命令是：UT

V1.4.1 更新内容
    2008.07.05 增加STT命令用于解决文字显示成问号的问题.
    2008.07.05 断面展开命令增加对选择的展开系数表的记忆功能,每次执行时会自动选择上次退出时选择的展开系数表.

因更早的版本只在小范围内发布，此处省略更新内容。


免费与捐助

一，免费与捐助

    本软件为免费软件，软件开发的初衷是自己使用的，由于我自己做的都是连续模,模具结构比较单一，目前软件已完全满足本人自用需求，如果继续开发下去将花费大量的私人时间和精力，论坛和群升级也需要费用，如果您觉得本软件给您带来有价值的帮助，并愿意提供一些资金支持的话，请选择捐助，我对您的支持表示衷心的感谢，我将对捐助过的朋友提出的合理的软件功能需求予以改进升级，并设有专用的QQ群作为捐助者交流场所，尽可能的提供软件或技术上的支持。当然作为免费软件，即使您无力捐助，也仍然可以使用到软件的全部功能。

二，捐助的金额

    您完全有权利决定捐助与否和捐助金额。

三，捐助流程

    1、支付宝方式在线支付
          支付宝账号：caizj2000@126.com
          账户名：蔡智军
          说明：点击访问支付宝网站

    2、银行转账支付
          开户银行：中国银行昆山张浦支行
          银行卡号：6013826101032044633
          开户名字：蔡智军

          开户银行：中国农业银行昆山陆杨支行
          银行卡号：6228480401856357215
          开户名字：蔡智军

        注：1.为了便于确认，建议您转账时金额要加小数，如200.21元。
            2.银行卡转帐时一定要核对开户名字。

    3、如以上捐助方法都不适合您，可点击这里与我联系。

四，关于捐助用户

    请给我发一封Email，里面说明您的身份和捐助金额，以便我知道您的捐助。
    收到汇款和Email后，我将第一时间通知您，并将您的Email保存下来。

五，补充说明

    强烈建议使用支付宝在线支付方式进行捐助，不需要银行帐号，不需要网上银行，方法很简单，有邮局就行(以下摘自支付宝网站)：
        第一步：带着现金到邮局储蓄专柜，记得要去省外汇款窗口哦；
        第二步：向服务人员要一张“邮政网汇e”的存款单；
        第三步：填写要充值的金额和汇款人姓名；不用填写收款人姓名哦。
        第四步：交给服务员填写好的网汇e存款单和相应的人民币，根据提示设定密码，之后把回单一定拿好，记牢密码离开；
        第五步：上网登录支付宝帐户(没有可以立即免费申请)，点击充值->网点充值->“邮政网汇e”在那里填上回单的帐号和你设定的密码，提交就成功啦；
        第六步：点“我要付款”->"直接给亲朋好友付钱"->"收款方支付宝账户:Caizj2000@126.com"


表格生成